Block Torrent by Mikrotik

/ip firewall layer7-protocol>
add comment=”” name=torrentsites regexp=”^.*(get|GET).+(torrent|\

/ip firewall filter>
add chain=forward src-address= layer7-protocol=torrentsites action=drop comment=torrentsites
add chain=forward src-address= protocol=17 dst-port=53 layer7-protocol=torrentsites action=drop comment=dropDNS
add chain=forward src-address= content=torrent action=drop comment=keyword_drop
add chain=forward src-address= content=tracker action=drop comment=trackers_drop
add chain=forward src-address= content=getpeers action=drop comment=get_peers_drop
add chain=forward src-address= content=info_hash action=drop comment=info_hash_drop
add chain=forward src-address= content=announce_peers action=drop comment=announce_peers_drop
add chain=forward src-address= p2p=all-p2p action=drop comment=p2p_drop


Leave a Reply

Fill in your details below or click an icon to log in: Logo

You are commenting using your account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s